Banking Circle Connect: Account Balances issues
Incident Report for Banking Circle
Resolved
This incident has been resolved.
Posted Sep 27, 2024 - 10:13 CEST
Investigating
We are investigating an issue regarding Account Balances. We are working on the issue and will provide updates.
Posted Sep 27, 2024 - 08:48 CEST
This incident affected: Accounts and Balances.