Banking Circle Connect: Connectivity issues

Incident Report for Banking Circle

Resolved

This incident has been resolved.
Posted Mar 23, 2025 - 12:27 CET

Monitoring

Services should be back online, and we are actively monitoring the situation before closing the incident.
Posted Mar 23, 2025 - 12:10 CET

Investigating

We are investigating an issue regarding clients connectivity to Banking Circle Connect and other components (reporting, FX).
We are working on the issue and will provide updates.
Posted Mar 23, 2025 - 11:31 CET
This incident affected: Connect UI Login.