FX and Payment Processing issues

Incident Report for Banking Circle

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 15:10 CEST

Monitoring

Reporting, notifications and balances should now be updating for clients.
BC will continue to monitor.
Posted Apr 01, 2025 - 14:50 CEST

Identified

Whilst payments are processing, we are aware of some delays in Reporting and Status updates showing on BC UI.
This is currently being worked on and Banking Circle are working on a fix to show the correct status and deliver reporting/notifications.
Posted Apr 01, 2025 - 14:08 CEST

Monitoring

The issue has now been resolved and we are now processing transactions.
Banking Circle will continue to monitor this.
Posted Apr 01, 2025 - 12:27 CEST

Identified

We are facing connectivity issues with an External Provider. They are aware of the issues.

Currently all payments will be held in a Pending Processing Status. FX is also impacted.

Our provider is working on a resolution, and we will update in due course.
Posted Apr 01, 2025 - 11:36 CEST

Update

We are continuing to investigate this issue.
Posted Apr 01, 2025 - 11:23 CEST

Investigating

We are investigating an issue regarding FX and Payment Processing. Payment may be showing as Pending Processing.
We will provide updates as soon as new information is available.
Posted Apr 01, 2025 - 11:14 CEST
This incident affected: Accounts and Balances, Reporting, and Notifications.