Delayed status updates for payments

Incident Report for Banking Circle

Resolved

A fix has been implemented, and the incident is resolved. We will continue to monitor the situation.
Clients will gradually see balances updating for pending transactions.
Posted Jul 02, 2026 - 04:43 CEST

Identified

We are currently experiencing a technical issue affecting our core banking system.
Real time instant payments are continuing to process as normal but balance updates in our online portal may be delayed or not reflect recent activity. FX Trade settlement is delayed. We are actively working to remediate this issue.
Posted Jul 02, 2026 - 03:51 CEST
This incident affected: Accounts and Balances, Reporting, and Notifications.