Delays in transactions being synced to clients accounts.

Incident Report for Banking Circle

Resolved

This incident has been resolved.
Posted Sep 01, 2025 - 13:35 CEST

Investigating

We are aware of some delays in transactions being synced to clients accounts.
Transactions are processing however the sync towards clients accounts and balances may be impacted.
Investigation is ongoing and we are working on a resolution.
Posted Sep 01, 2025 - 13:00 CEST
This incident affected: Accounts and Balances.