Inbound Payments not being applied to clients accounts

Incident Report for Banking Circle

Resolved

We have now cleared the backlog of transactions. This incident has been fully resolved and there is no impact on clients accounts.
Posted Sep 03, 2025 - 16:00 CEST

Monitoring

We have implemented a corrective measure that has reduced the number of payments not appearing on client accounts. Efforts are ongoing to ensure that all affected transactions are fully reflected.
Posted Sep 03, 2025 - 15:34 CEST

Update

We are continuing to work on a fix for this issue.
Posted Sep 03, 2025 - 15:32 CEST

Identified

We believe that we have identified the underlying cause of the problem and are currently implementing a fix to mitigate the situation.
Posted Sep 03, 2025 - 14:08 CEST

Investigating

We are aware of an issue with Inbound Payments not being applied to clients accounts. We are currently investigating the problem internally.
Posted Sep 03, 2025 - 13:52 CEST
This incident affected: Accounts and Balances.